A lot of the NetarchiveSuite source code is written with very compact naming of variables and methods, which doesn't include much information about the purpose of the variable or methods. The result is that the code can become very difficult to read. This has sometimes has been mitigated by adding inline comments. Writing readable code is in my opinion is fare far superior to incomprehensible code riddled with comments.
...
Code Block |
---|
public void testSubmitNewJobsMakesDuplicateReductionInfo() {
clearExistingJobs();
...
}
/**
* Clear the existing jobs by running a <code>submitNewJobs</code> on the scheduler.
*
* @throws Exception
*/
private void clearExistingJobs() throws Exception {
Method submitNewJobMethod = ReflectUtils.getPrivateMethod(HarvestScheduler.class, "submitNewJobs");
submitNewJobMethod.invoke(harvestScheduler);
} |
...